You need to explicitly set permissions for Dashlets to be displayed directly after login. In order to do this, go to User Preferences. From the Open on Start combo, select the Dashboard you would like to appear e.g. the one just saved.